Problem
You receive an error message indicating that the cache directory cannot be created or is not writable.
Cause
The WP Cloud plugins store cache data in the /wp-content/[WP Cloud Plugin Name]-cache/
folder. For the plugin to function properly, this folder must exist and be writable. This error occurs when the plugin cannot create the cache folder or when the folder is not writable. Usually, the plugin should resolve this automatically, but server file/folder permissions may not be set to the default WordPress values, preventing the necessary changes.
Solution
-
Update Folder Permissions
Navigate to the/wp-content/[WP Cloud Plugin Name]-cache/
folder via FTP and update the folder permissions to 755.- If the permissions are already set to 755, try manually copying the contents of the
/wp-content/plugins/[WP Cloud Plugin Name]/cache/
folder into the/wp-content/[WP Cloud Plugin Name]-cache/
folder.
- If the permissions are already set to 755, try manually copying the contents of the
-
Solution 2: Define a Custom Cache Folder Location
You can define your own cache folder location for the plugin by adding the following lines to yourwp-config.php
file:define('[PLUGIN_SLUG]_CACHEDIR', WP_CONTENT_DIR.'/uploads/[PLUGIN_SLUG]-cache/');
define('[PLUGIN_SLUG]_CACHEURL', content_url().'/uploads/[PLUGIN_SLUG]-cache/');
[PLUGIN_SLUG]
=
SHAREONEDRIVE for OneDrive/SharePoint plugin
OUTOFTHEBOX for Dropbox plugin
USEYOURDRIVE for Google Drive plugin
LETSBOX for Box plugin
Please feel free to submit a support ticket if this does not resolve the issue.